Litoli
12.01.2020 18:24

7. Составьте программу под
счета числа положительных,
отрицательных, нулевых эле-
ментов линейной таблицы
контрольный пример: n=5
данные: А=(1,0,3,0, -5)
результат: пол=2; отр=1, нул=2​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Kravtskris
28.07.2020 01:03

Обычно предполагается, что нам известны какие-либо начальные данные. Тогда для простоты, буду считать что нам известно основание и высота к этому основанию. В таком случае

S = основание * высоту / 2

Что нужно сделать?

1) Запросить у пользователя ввод длины основания

2) Запросить у пользователя ввод длины высоты

3) Вычислить площадь

4) Вывести площадь на экран

Определимся с данными. У нас будет переменная S, основания и высоты. Все будут real, ведь пользователь может ввести и не целое число.

program ploshad;

var S, osnovanie, visota:real;

begin

   writeln('Вычисление площадь треугольника по основанию и высоте');

   writeln('Введите длину основания ');

   read(osnovanie);

   writeln('Введите длину высоты ');

   read(visota);

   S:=osnovanie*visota/2;

   writeln('Площадь треугольника = ',S);

end.

0,0(0 оценок)
Ответ:
Пелагея9087
27.02.2023 08:17
1). Ніколи не давайте приватної інформації про себе (прізвище, номер телефону, адресу, номер школи) без дозволу батьків.
2). Завжди дотримуйтесь сімейних правил Інтернет-безпеки: вони розроблені для того, щоб ви почували себе комфортно і безпечно у мережі.
3). Завжди будьте ввічливими у електронному листуванні, і ваші приятелі будуть ввічливими з вами.
4). Не розсилайте листи з будь-якою інформацією незнайомим людям без їхнього прохання - це сприймається як "спам", і звичайно засмучує користувачів мережі.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота