drovniashinaan
03.11.2021 13:59

Нужно решить данные . буду признателен. 1. составьте программу ввода и вывода массива: 3,4,-9,8,1,-6,2,-5,-1,7,5,9. 2. составьте блок-схему алгоритма и программу вычисления в массиве а(10) количества отрицательных эллементов. 3. составьте программу вычисления в массиве в(8) суммы четных элементов.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
мари420
14.06.2020 16:15

1)
Ввод чисел в массив:
program vvod_mass;
var
a: array[1..12] of integer;
i: integer;
begin
for i:=1 to 12 do
begin
write('a[', i, ']='); readln(a[i]);
end;
end.
2)
program otric;
var
a: array[1..10] of integer;
i,n: integer;
begin
randomize;
for i:=1 to 10 do
begin
a[i]:=-10+random(21);
writeln(a[i]);
end;
for i:=1 to 10 do if a[i]<0 then inc(n);
write('Кол-во отрицательных чисел массива: ', n);
end.
3)
program chetniy;
var
a: array[1..8] of integer;
i,n: integer;
begin
randomize;
for i:=1 to 8 do
begin
a[i]:=-10+random(21);
writeln(a[i]);
end;
for i:=1 to 8 do if a[i] mod 2 = 0 then inc(n);
write('Кол-во отрицательных чисел массива: ', n);
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота