pahan250
11.09.2022 14:15

Написать программу, которая формирует случайным образом массив из n целых чисел, лежащих в диапазоне от 1 до 5, после чего на экран выводится сам массив и номера элементов, с первым элементом

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Skotonyaka
14.06.2020 14:59

const

  N = 5;

 

var

  a: array [1..N] of integer;

  i: integer;

 

begin

  for i:= 1 to N do

    a[i]:= random(5) + 1;

  writeln('Сформированный массив:');

  for i:= 1 to N do

    writeln(a[i]);

  writeln('Номера элементов, совпадающих с первым элементом:');

  for i:= 2 to N do

    if a[i] = a[1] then writeln(i);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота