Помидоркин001
26.02.2021 11:58

Написать программу на паскале. в трёхзначном числе вывести максимальную цифру из этого числа.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Sk174
20.04.2022 18:10

Элементы, чтобы не вводить заполняются автоматически

#include <iostream>

#include <ctime>

using namespace std;

int main()

{

   int n, i, m, mi;

   cin >> n;

   int a[n];

   srand((unsigned)time(NULL));

   for (i=0; i<n; i++)

   {

       a[i]=rand()%100;

       cout << a[i] << " ";

   }

   cout << "\n";

   m=a[0];

   mi=0;

   for(i=0;i<n;i++)

   {  if(m<a[i])

       {  m=a[i];

          mi=i;

       }

   }

   for(i=1;i<mi;i+=2)

       a[i]=a[i]*m;

   cout << "max element a[" << mi << "]=" << m << "\n";

   for (i=0; i<n; i++)

       cout << a[i] << " ";

   return 0;

}


13. Дано натуральне число n і масив дійсних чисел a[1..n]. Всі елементи масиву з парними номерами, щ
0,0(0 оценок)
Ответ:
матиматик5а
20.12.2021 12:38

Элементы, чтобы не вводить заполняются автоматически

#include <iostream>

#include <ctime>

using namespace std;

int main()

{

   int n, i, m, mi;

   cin >> n;

   int a[n];

   srand((unsigned)time(NULL));

   for (i=0; i<n; i++)

   {

       a[i]=rand()%100;

       cout << a[i] << " ";

   }

   cout << "\n";

   m=a[0];

   mi=0;

   for(i=0;i<n;i++)

   {  if(m<a[i])

       {  m=a[i];

          mi=i;

       }

   }

   for(i=1;i<mi;i+=2){

       a[i]=a[i]*m;

   }

   cout << "max element a[" << mi << "]=" << m << "\n";

   for (i=0; i<n; i++)

   {

       cout << a[i] << " ";

   }

   return 0;

}


13. Дано натуральне число n і масив дійсних чисел a[1..n]. Всі елементи масиву з парними номерами, щ
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота