Написать программу, которая считывает с экрана монитора два числа и вычисляет сумму квадратов этих двух чисел. Вывод результата выполнить с пояснением. Это Python.
Var a1,a2,a3,a4,a5,a6,a7,a8,k:integer; begin k:=0; read (a1,a2,a3,a4,a5,a6,a7,a8); if (a1>0) and (a2>0) and (a3>0) and (a4>0) and (a5>0) and (a6>0) and (a7>0) and (a8>0) then begin if (a1 mod 3 = 0) and (a1 mod 10 = 4) then k:=k+1; if (a2 mod 3 = 0) and (a2 mod 10 = 4) then k:=k+1; if (a3 mod 3 = 0) and (a3 mod 10 = 4) then k:=k+1; if (a4 mod 3 = 0) and (a4 mod 10 = 4) then k:=k+1; if (a5 mod 3 = 0) and (a5 mod 10 = 4) then k:=k+1; if (a6 mod 3 = 0) and (a6 mod 10 = 4) then k:=k+1; if (a7 mod 3 = 0) and (a7 mod 10 = 4) then k:=k+1; if (a8 mod 3 = 0) and (a8 mod 10 = 4) then k:=k+1; writeln (k); end else writeln ('Неверный ввод'); end.
Const N = 10; Var A:array[1..N] of integer; i,j,M,B,C,p,s:integer; Begin Randomize; {Заполнение и вывод} Write('Исходный массив:'); For i:= 1 to N do Begin A[i]:=random(N); Write(' ',A[i]); End; WriteLn; {Сортировка} p:=0; For i:= 1 to N do Begin M:=i; For j:= i+1 to N do if A[j]<A[M] then M:=j; if M<>i then Begin B:=A[M]; A[M]:=A[i]; A[i]:=B; p:=p+1; {Вывод каждого шага сортировки} Write('Перестановка №',p,':'); For j:= 1 to N do Write(' ',A[j]); WriteLn; End; End; WriteLn; Write('Отсортированный массив:'); For i:= 1 to N do Write(' ',A[i]); {Бинарный поиск} WriteLn; Write('Введите число: ');ReadLn(C); m:=N div 2; i:=1; j:=N; s:=0; While (A[m]<>C)and(i<=j) do Begin if C > A[m] then i:=m+1 else j:=m-1; s:=s+1; m:=(i+j) div 2; End; WriteLn; if A[m]=C then WriteLn('В массиве есть данное число') else WriteLn('В массиве нет данного числа'); WriteLn('Кол-во перестановок за сортировку: ',p); WriteLn('Кол-во сравнений за поиск: ',s); End.