Губотрах
26.12.2022 14:08

программирование 8 класс c++ Дан целочисленный массив В[1..5, 1..5]. Вычислить произведение элемен-
тов этого массива, расположенных ниже левой диагонали.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Сумасшедшая55555
20.02.2023 04:12

ответ:1. Расширение и развитие дизайна как вида проектной деятельности, охват им новых областей приложения обусловлены сутью и методологическими особенностями дизайн-проектирования, отмеченными выше.

Смысловые корни термина «дизайн» восходят к латинскому «designare» — определять, обозначать. Итальянское «disegno» со времен Ренессанса обозначало проекты, рисунки, а также основополагающие идеи. В Англии понятие «design» рас в XVI веке.

Этимология (первоначальные значения) англоязычного понятия «дизайн» охватывает несколько смысловых рядов.

Генетически первичным является ряд определений «декоративного» порядка: узор, орнамент, декор, украшение, убранство.

Ко второму ряду относятся «проектно-графические» трактовки: набросок, эскиз, рисунок, собственно проект, чертеж, конструкция. Третий ряд, выходящий за рамки прямого проекта, это «предвосхищающие» понятия: план, предположение, замысел, намерение.

И, наконец, четвертый ряд определений — неожиданно «драматический»: затея, ухищрение, умысел и даже интрига.

Этот широкий спектр англоязычных значений в сочетании с острой социальной направленностью традиционного дизайна при особом внимании к проблемам «человеческих факторов» достаточно полно соответствует обозначению новых разновидностей проектной деятельности. Отечественные термины, употреблявшиеся с начала 1960-х до 1980-х годов — «художественное конструирование» (официальное государственное) и «художественное проектирование» (в среде художников, искусствоведов и философов), — были более конкретными и одновременно более узкими по значению.

правленность, структурное единство всех элементов.

0,0(0 оценок)
Ответ:
longassride
20.09.2022 00:27
// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
begin
  var n:=ReadInteger('Количество элементов массива ');
  var m:=ArrRandom(n,-50,50); m.Println(', ');
  var a:=0; var b:=0; var c:=0;
  for var i:=0 to n-1 do begin
    if m[i]>0 then a:=a+m[i];
    if m[i]<m[b] then b:=i;
    if m[i] mod 5 = 0 then Inc(c)
  end;
  var w:=(b+1)+a/(c+1);
  WritelnFormat('A={0}, B={1}, C={2}, W={3}',a,b+1,c,w);
  Writeln('Принято, что элементы массива нумеруются от единицы')
end.

Тестовое решение:
Количество элементов массива  13
-43, -15, 18, -8, -13, -47, -36, 6, -16, 45, 33, 33, -24
A=135, B=6, C=2, W=51
Принято, что элементы массива нумеруются от единицы

Составить программу вычисления, w = b + a - сумма положительных элементов массива; b – номер наимень
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота