bulyginanastya
06.01.2022 18:24

Напишите программу в Паскале, которая переводит переданное её целое число (возможно, отрицательное) в восьмеричный код. Используйте процедуру. Входные данные
Входная строка содержит целое число N .

Выходные данные
Программа должна вывести восьмеричное представление переданного её числа.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nikzyryanov02
19.04.2020 03:27
Такое задание уже было. Я на него отвечал, думаю модераторы не против, если свой же ответ здесь предоставлю)
  Только первых три

Задача 1:
var p: array[1..10] of integer;  
i:integer;
count:integer;
begin
for i:=1 to 10 do read(p[i]);
write('Сколько цифр массива хотите видеть? -> '); 
readln(count);
for i:=1 to count do write(p[i]:3);
end.

Задача 2:

var arr: array[1..10] of integer;   
i:integer;    
s:integer;    
count:integer;
begin
for i:=1 to 10 do
begin
arr[i]:=Random(-10,10);
if(arr[i]<0) then
begin
writeln(arr[i]:4);
s:=s+arr[i];
count:=count+1;
end;
end;
writeln('Среднее значение = ', s/count);
end.

Задача 3:

var arr: array[1..10] of integer;    
i:integer;    
crat:integer;    
id:integer;       
begin   
for i:=1 to 10 do   
begin   
read(arr[i]);   
crat:=arr[i] mod 3;   
if(crat = 0) then   
begin   
id:=arr[i];     
if(arr[i] = id) then writeln('Id = ', i:2);    
end;   
end;   
end.
0,0(0 оценок)
Ответ:
ιιIαγρμα
16.01.2020 21:22
#include <iostream>
using namespace std;
int main() {
    cout<<–2013<<" "<<21<<" "<<56<<endl;
    cout<<–2.034<<" "<<1.15<<" "<<5.36<<endl;
    cout<<"– 2 0 1 5"<<endl;
    cout<<"Наступил 2015 год"<<endl;
    cout<<"Поздравляю Всех с Новым"<<endl<<"2 0 1 5"<<endl<<"годом !"<<endl;
    cout<<"Выполнила задание"<<endl<<"Радченко Мария Александровна"<<endl
        <<"слушатель группы ЗМС-14-4"<<endl;
    system("PAUSE");
    return 0;
}

Результат выполнения программы:
-2013 21 56
-2.034 1.15 5.36
- 2 0 1 5
Наступил 2015 год
Поздравляю Всех с Новым
2 0 1 5
годом !
Выполнила задание
Радченко Мария Александровна
слушатель группы ЗМС-14-4
Для продолжения нажмите любую клавишу . . .
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота