Lizzik657
02.06.2020 08:31

Нужно написать программу на Python которая будет выводить числа от 0 до X (число X введет пользователь) сперва в порядке возрастания, а потом в порядке убывания. Каждое число должно быть в новой строчке. Пример:
Пользователь ввел число 5. Программа выводит:
0
01
012
0123
01234
012345
01234
0123
012
01
0

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MaxTwAiNer12
12.02.2021 21:46

x = int(input())

s = '0'

for i in range(1,x+2):

   print(s)

   s += str(i)

for i in range(2,len(s)):

   print(s[:-i])

#с наступающим)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота