katrina7
22.06.2020 16:52

Напишите программу , которая выводит номера билетов, чтобы они не повторялись

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
artemnovik506
14.06.2020 06:49

Я так понимаю намера билетов надо вывести в случайном порядке?

Пусть надо вывести в случайном порядке номера 100 билетов

program RND;

var a:array[1..100]of integer;

i.j,f:integer;

begin

randomize;

i:=1;

white i<101 do begin

f:=0;

A[i]:=int(random(100));

for j:=1 to i do if A[j]=A[i] then f:=1;

if f=0 then i:=i+1;

end;

for i:=1 to 100 do writeln(A[i]);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота