niceglotatel
20.06.2022 23:19

Написать программу на C++ Дано: n, a[n][n]. Если на главной диагонали матрицы все элементы положительные, вычислить и вывести значение суммы элементов главной диагонали. Иначе напечатать сообщение «На главной диагонали есть отрицательные элементы».
Для решения задачи использовать динамическую память и генератор случайных чисел
p.s желательно с комментариями

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nasyatkachenko8
27.01.2021 17:33

#include <iostream>

#include <vector>

#include <cstdlib>

#include <ctime>

using namespace std;

int main() {

setlocale(LC_ALL, "Russian");

int sum = 0;

vector<vector<int>> arr;

arr.resize(10);

for (int i = 0; i < 10; ++i) {

 arr[i].resize(10);

}

for (int i = 0; i < 10; ++i) {

 for (int j = 0; j < 10; ++j) {

  arr[i][j] = rand();

  cout << arr[i][j] << " ";

  if (j == 9) {

   cout << endl;

  }

 }

}

for (int i = 0, j = 0; i < 10, j < 10; ++i, ++j) {

 if (arr[i][j] < 0) {

  cout << "На главной диагонали есть отрицательные числа...";

  return 0;

 }

 sum += arr[i][j];

}

cout << "Сумма элементов главной диагонали: ";

cout << sum;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота