nurik139
21.06.2020 14:19

Написать программу к задаче найти у=х*х+7*х

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ruslangusen
22.01.2023 02:44
#include "math.h"
#include <iostream>
using namespace std;
int main()
{
//объявление переменных
float xa, ya, xb, yb, ab ;
//ввод переменных 
cout<<"Vvedite xa: "<<endl;
cin>>xa;
cout<<"Vvedite ya: "<<endl;
cin>>ya;
cout<<"Vvedite xb: "<<endl;
cin>>xb;
cout<<"Vvedite yb: "<<endl;
cin>>yb;
//расчет длинны отрезка
ab=sqrt(pow(xa-xb,2)+pow(ya-yb,2);
//вывод длины отрезка
cout<<"|AB| = "<<ab<<endl;
system("pause");
return 0;
}
0,0(0 оценок)
Ответ:
Еролггштши
22.01.2023 02:44

Fasm

 

org 100h

mov si, string
cld

my_loop:
lodsb
cmp al, 0
jz loop_exit
cmp al, '0'
jb my_loop
cmp al, '9'
ja my_loop
sub al, '0'
add bx, ax
jmp my_loop

loop_exit:
push -1
mov ax, bx
loop_push:
xor dx, dx
div [d]
push dx
cmp ax, 0
jne loop_push
mov ah, 2h

print:
pop dx
cmp dx, -1
je exit
add dl, '0'
int 21h
jmp print

exit:
mov ah, 01h
int 21h
ret


d dw 10
string db "1", 0

 

FPC

 

var
s : string;
i, c : integer;
begin
readln (s);
c := 0;
for i := 1 to length (s) do
if (s[i] in ['0'..'9']) then inc (c, ord (s[i]) - ord ('0'));
writeln (c);
end.

 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота