Ниже на языке программирования Pascal записан алгоритм, который получает на вход число X и печатает два числа a и b: var x, a, b: integer;
begin
readln(x);
a:=0; b:=1;
while (x mod 10) > 1 do
begin
a:=a+(x mod 10);
b:=b*2;
x:=x div 10;
end;
writeln(a); write(b);
end.
Укажите наименьшее из таких чисел x, при вводе которых алгоритм сначала печатает 12, а потом 16.