ulchik4572
18.03.2022 03:55

Мы уже писали программу, вычисляющую сумму налога по прогрессивной шкале в зависимости от полученного заработка: 13% на доход до 10 000, 20% на доход от 10 000 до 50 000, 30% на доход выше 50 000. Однако во многих странах, использующих такую шкалу, эта сумма вычисляется более сложным налоговая ставка 30% на доход выше 50 000 означает, что 30% уплачивается не со всей суммы, а лишь с той ее части, которая превосходит 50 000. Аналогично, ставка 20% на доход от 10 000 до 50 000 обязывает уплатить 20% лишь с той части суммы, которая превосходит 10 000, но не превосходит 50 000.

Так, например, с дохода 100 000 придется заплатить такой налог:

30% * (100 000 − 50 000) + 20% * (50 000 − 10 000) + 13% * 10 000 = 15 000 + 8 000 + 1 300 = 24 300

А с дохода 30 000 — такой: 20% * (30 000 − 10 000) + 13% * 10 000 = 4 000 + 1 300 = 5 300

Напишите программу, которая спрашивает у пользователя его доход и высчитывает сумму налога для него по вышеописанным правилам
в питоне

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
erkr
05.06.2022 22:27

Проще всего работать с этим числом как со строкой, и переставить местами нулевой и первый символ. Другой работать с числом, разобрать его на цифры и переставить их нужным образом.

Я реализую второй подход. Для трёхзначного числа цифры можно выделить так:

n % 10  (остаток от деления на 10) - последняя цифра

n / 10 дает целую часть от деления на 10, т.е. по сути отбрасывает последнюю цифру, тогда (n / 10) % 10 - вторая цифра

n / 100 - целая часть от деления на 100, первая цифра.

Код (C++):

#include <iostream>

int main() {

   int n;

   std::cin >> n;

   std::cout << (n / 10) % 10 << n / 100 << n % 10;

}

0,0(0 оценок)
Ответ:
bogdan2041
28.02.2021 16:57
Хосспаде Иегове, да научитесь же вы язык указывать! Perl.
2.
@array; #Формат ввода не задан, будем считать что он уже заполнен.
$min = $array[0];
$max = $array[0];
for $i (@array) {
    $min = $i if ($i < $min);
    $max = $i if ($i > $min);
}
%hash = map {$_ => 1} @array;
for $i in ($min..$max) {
    print "$i " if (!(exists $hash{$i}));
}
3.
use Quantum::Superpositions; #Модуль для квантовых вычислений, жутко удобная штука.
@primes;
$n = <>;
push @primes, ($i) if ($i % all(2..sqrt($i)+1) != 0) i for $i (2..$n);
#ответ в массиве @primes.
4. На этот вопрос я не так давно отвечал, ну ладно.
$n = <>;
@multipliers;
for $i (2..$n) {
    if (!($n % $i)) {
        push @multipliers, ($i);
        $n /= i;
    }
}
#ответ в массиве @multipliers.
А теперь укажите-таки язык и я, если с этим языком знаком напишу нормальный, не извращённый ответ.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота