roofman93p08nel
11.07.2021 01:04

Программа на Паскале: Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x,y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы. Программа была написана неправильно. var x,y: real;

begin readln(x,y);

if y =0 then

if y>=−(x−1)2+1 then

write('принадлежит')

else

write('не принадлежит')

end.

При каком(-их) значении(-ях) х и у программа выполняется неправильно?

Выберите один ответ:

a. x = 0; y = -1;

b. x=0; y=1;

c. x=1; y=2;

d. x = 1,5; y = -10,5;


Программа на Паскале: Требовалось написать программу, которая вводит с клавиатуры координаты точки н

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ПеЧеНьКа5608
31.10.2021 19:35

#include <iostream>

using namespace std;

void swap(int *a, int *b){

   int temp = *a;

   *a = *b;

   *b = temp;

}

signed main() {

   int ans = 0;

   int n;

   cin >> n;

   int arr[n];

   for(int i = 0; i < n; i++)

       cin >> arr[i];

   for (int i = 0; i < n-1; i++){

       for (int j = 0; j < n-i-1; j++){

           if (arr[j] < arr[j+1]){

               swap(&arr[j], &arr[j+1]);

               ans += (arr[j] - arr[j+1])*2;

           }

       }

   }

   cout << ans;

}

P.S: задачка не тупая, хороший вариант для понимания bubble sort'а

0,0(0 оценок)
Ответ:
kolakao
31.10.2021 19:35

#include <iostream>

using namespace std;

void swap(int *a, int *b){

   int temp = *a;

   *a = *b;

   *b = temp;

}

signed main() {

   int ans = 0;

   int n;

   cin >> n;

   int arr[n];

   for(int i = 0; i < n; i++)

       cin >> arr[i];

   for (int i = 0; i < n-1; i++){

       for (int j = 0; j < n-i-1; j++){

           if (arr[j] < arr[j+1]){

               swap(&arr[j], &arr[j+1]);

               ans += (arr[j] - arr[j+1])*2;

           }

       }

   }

   cout << ans;

}

P.S: задачка не тупая, хороший вариант для понимания bubble sort'а

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота