musmus11
19.11.2022 18:28

Нужна ваша по программированию. ответьте на 1 вопрос Составьте программу вычисления среднего арифметического целых чисел из отрезка [-4; 15].

#include
#include
void main()
{
setlocale(LC_ALL, "Rus");
int n = 0;
float sr_arifm;
for (int i = -4; i <= 15; i++)
n += i;
sr_arifm = n / float(15 - (-4) + 1);
printf("Среднее арифметическое на отрезке [-4;15]=%f", sr_arifm);
}

ВОПРОС: С какой целью использовано (float)(15)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ПРИВЕТ174rus
24.01.2021 21:43

Без float программа выдает ответ 5,0, а с float ответ 5,5.

Float это вещественного тип.

Их значения имеют дробную часть, отделяемую точкой, например: -5.6, 31.28

Объяснение:

#include <stdio.h>

#include <iostream>

using namespace std;

int  main()

{

setlocale(LC_ALL, "Rus");

int n = 0;

float sr_arifm;

for (int i = -4; i <= 15; i++)

n += i;

sr_arifm = n / float(15 - (-4) + 1);

printf(" Сред арифм [-4;15]=%f", sr_arifm);

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота