Shkolnik12345678910
14.12.2022 14:08

до завтра С / С ++
можно заново написать программу, можно доработать мой вариант, главное чтобы все работало
ЗАДАНИЕ:
Написать программу, которая считает сумму введенных чисел и завершает выполнение по нажатию символа, "q". При введении другого символа (не цифры) программа имеет выдать сообщение об ошибке и продолжить работу.
Мой вариант программы (вложенное фото) считает сумму отдельных цифр например 123 45 сумма будет 1 + 2 + 3 + 4 + 5. А нужно 123 + 45.
Можно полноценный код программы

за ответы не касающиеся данной задачи получите бан


до завтра С / С ++ можно заново написать программу, можно доработать мой вариант, главное чтобы все

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Mikich2
29.08.2020 04:22

#include <iostream>

#include <time.h>

#include<cstdlib>

#include <iomanip>

using namespace std;  

int main() {

setlocale(LC_ALL, "rus");

srand(time(NULL));

int m, n; //ЧИСЛЛО СТРОК , СТОЛБЦОВ  

int S=1; // БУДУЩЕЕ ПРОИЗВЕДЕИЕ  

cin >> m >> n; // ВВОДИМ ИХ

int A[m][n];           //ОБЪЯВЛЯЕМ МААССИВ  

for (int i = 0; i < m; i++) {            // ЦИКЛ ЗАПОЛНЕНИЯ МАССИВА СЛУЧАЙНЫМИ ЧИСЛАМИ  

 for (int j = 0; j < n; j++) {

  A[i][j] = rand()%200 - 100;

 }

}

for (int i = 0; i < m; i++) {

 for (int j = 0; j < n; j++) {// ЦИКЛ ВЫПОЛНЕНИЯ УСЛОВИЯ  

  if (A[i][j]<0&&j%2==1){

   if (i%2==0){

    S=S*A[i][j];

   }

  }

 }

}

for (int i = 0; i < m; i++) {// ВЫВОД МАССИВА  

 for (int j = 0; j < n; j++) {

  cout << setw(3)<<A[i][j]<< "    ";  

 }

 cout << endl ;  

}

cout << endl << S;// ВЫВОД ПРОИЗВЕДЕНИЯ  

return 0 ;

}

0,0(0 оценок)
Ответ:
lalalol1
17.02.2020 05:13
1. Найдем мощность алфавита: N = 33 русских прописных буквы + 33 русских строчных букв + 21 специальный знак = 87 символов.Подставим в формулу и рассчитаем количество информации: 2. I = log287 = 6,4 бита. Такое количество информации - информационный объем - несет один символ в русском тексте. Теперь, чтобы найти количество информации во всем тесте, нужно найти общее количество символов в нем и умножить на информационный объем одного символа. Пусть в тексте 3000 символов. Значит: 3. 6,4*3000 =19140 бит.Теперь дадим задание переводчику перевести этот текст на немецкий язык. Причем так, чтобы в тексте осталось 3000 символов. Содержание текста при этом осталось точно такое же. Поэтому с точки зрения вероятностного подхода количество информации также не изменится, т.е. новых и понятных знаний не прибавилось и не убавилось.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота