![Составить программу и блок схему нахождения а)суммы элементов массива С[1..30] б)количества элементо](/tpl/images/4158/2144/ebaf4.jpg)
ответ:Многие страны перешли на т.н. «информационное общество», некоторые – в процессе перехода, в зависимости от факторов, влияющих на то или иное население. Все меньше уделяется внимания печатным изданиям: ученные говорят о том, что лет через 30 газеты, журналы, книги исчезнут с прилавков.
С одной стороны, электронные страницы – это хорошо, меньше вреда наносится окружающей среде, да и хранить большое количество информации легче и удобнее в электронном виде. С другой стороны – человечество становится все более зависимым от техники.
31
Объяснение:
/** libraries */
#include <iostream>
#include <cmath>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <algorithm>
/** libraries */
using namespace std;
/** defines */
#define ll long long
#define ld long double
#define yes cout << "YES" << "\n"
#define no cout << "NO" << "\n"
/** defines */
ll to_10(ll num){
ll i = 0,res = 0;
while(num > 0){
res += pow(2,i) * (num % 10);
num /= 10;
i++;
}
return res;
}
signed main() {
ios_base::sync_with_stdio(false);
cin.tie(nullptr);
cout.tie(nullptr);
for(ll x = -1000000; x <= 1000000; x++){
if(x - to_10(11110) > 0&&to_10(11) * to_10(1001) - sqrt((to_10(101011) + to_10(111001))/(x-to_10(11110))) == to_10(10001)){
cout << x;
return 0;
}
}
}