ĪīDanilaīī
24.07.2020 08:32

Калькулятор на паскале с объяснением кода

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
fedivvasil19
06.02.2022 00:11

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018

var c, w: integer;

procedure check;

begin

 var (a, b) := (Random(0, 20), Random(0, 20));

 Print($'{a}*{b}=');

 if a * b = ReadInteger then begin inc(c); Println('Правильно') end

 else begin inc(w); Println('Неправильно') end;

end;

procedure res;

begin

 Println($'Задано вопросов {c+w}');

 Println($'Правильных {c}({(c*100)/(c+w):f1}%)');

 Println($'Неправильных {w}({(w*100)/(c+w):f1}%)');

end;


begin

 var start := true;

 while start do

 begin

   Println('Проверим?(0/1)');  

   if ReadInteger = 0 then

   begin start := false; res; end

   else check;

 end;

end.


Пример в приложении.


Составить программу проверки знания таблицы умножения. сценарий: компьютер спрашивает: «проверим? »
0,0(0 оценок)
Ответ:
3HAIKa11
06.02.2022 00:11

//Язык Pascal

Program multiplication;


Var

  code, rightAnswers, mistakes, answersCount, value1, value2, answer: integer;


Begin


  Randomize;

   

  code := 1;

  rightAnswers := 0;

  mistakes := 0;

  answersCount := 0;

   

  while code = 1 do

  begin

     Write('Проверим? ');

     Readln(code);

     Writeln();

     

     if (code = 1) then

     begin

        value1 := random(1, 9);

        value2 := random(1, 9);

         

        Write(value1, '*', value2, ' = ');

        Readln(answer);

         

        if (answer = value1 * value2) then

        begin

           Writeln('Правильно!');

           rightAnswers := rightAnswers + 1;

        end

         

        else

        begin

           Writeln('Неправильно!');

           mistakes := mistakes + 1;

        end;

         

        answersCount := answersCount + 1;

        Writeln();

     end;

  end;

   

  Writeln('Статистика:');

  Writeln('Задано вопросов: ', answersCount);

  Writeln('Количество правильных ответов: ', rightAnswers);

  Writeln('Число ошибок: ', mistakes);


End.


Программа в паскале составить программу проверки знания таблицы умножения. сценарий: компьютер спраш
Программа в паскале составить программу проверки знания таблицы умножения. сценарий: компьютер спраш
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота