rejnmasha2018
16.12.2022 15:10

Задача: Дан двумерный массив целых чисел. Вывести все строки, в которых есть трёхзначные натуральные числа.

Формат ввода:

На первой строке, заданы два натуральных числа, не превосходящие 50 - количество строк и столбцов соответственно.
Далее массив целых чисел задан построчно, через 1 пробел. Числа в диапазоне от -30000 до 30000

Формат вывода:

Выбранные строки массива, через 1 пробел.

Пример входных данных

4 3
13 24 35
163 671 28
12 -61 -50
-8 -6 100
Пример выходных данных

163 671 28
-8 -6 100
Пояснение:

Отсутствует.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ада20000
22.09.2022 06:48
var
  a, b, c, d, i, n, p: integer;
  x, y: real;

begin
  writeln('Задача 1, введите n =');
  read(n);
  for i := 1 to n do
    if i mod 2 = 0 then
      x := x + 1 / (2 * i + 1)
    else x := x - 1 / (2 * i + 1);
  writeln('Sum = ', x);
 
  writeln('Задача 2, введите a, b, c, d =');
  read(a, b, c, d);
  for i := a to b do
    if i mod c = d then writeln(i);
 
  writeln('Задача 3, введите n и n чисел =');
  read(n);
  a := 0; b := 0; c := 0;
  for i := 1 to n do
  begin
    read(p);
    if p = 0 then a := a + 1
    else if p < 0 then b := b + 1
    else if p > 0 then c := c + 1;
  end;
  writeln(a, ' ', b, ' ', c);
 
  writeln('Задача 5, введите x, p ,y =');
  read(x, p, y);
  n := 0;
  repeat
    x := round(x * (100 + p)) / 100;
    n := n + 1;
  until x >= y;
  writeln(n, ' лет');
 
  writeln('Задача 6, введите A, B =');
  read(a, b);
  repeat
    if (a mod 2 = 0) and (a div 2 >= b) then begin
      writeln(a, ' : 2 = ', a div 2);
      a := a div 2
    end
    else begin
      writeln(a, ' - 1 = ', a - 1);
      a := a - 1;
    end;
  until a <= b;
end.
0,0(0 оценок)
Ответ:
VadimShoppert
22.09.2022 06:48

Школьные Знания.com


Какой у тебя вопрос?

10 - 11 классыИнформатика 8+4 б



Дан массив вещественных чисел:


Все элементы с нечетными номерами заменить на их квадратный корень



Отметить нарушение РРПП 01.04.2013

ответы и объяснения

Проверенный ответ

Tlalok

Tlalok Почетный грамотей

var


a:array[1..100] of real;


i, n:integer;


begin


write('Введите количество элементов '); readln(n);


for i := 1 to n do


begin


write('a[', i ,'] = ');


readln(a[i]);


end;


writeln;


writeln('Исходный массив:');


for i := 1 to n do


begin


write(a[i], ' ');


if i mod 2 = 1 then


a[i] := sqrt(a[i]);


end;


writeln;


writeln;


writeln('Преобразованный массив:');


for i := 1 to n do


write(a[i]:0:2, ' ');


writeln;


end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота