kat243
20.02.2020 03:05

1. Напишите программу, которая определяет среднее арифметическое двух чисел, если «a» положительное. И частное (a/b), если «a» отрицательное. Значения переменных должны вводиться с клавиатуры! Записать алгоритм на ШАЯ в этом файле с соблюдением правил написания в Кумире.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
KaguraChan
09.01.2021 00:15
//Dev-C++ (С)

#include <stdio.h>

int main(void)
 {int DepHour,DepMin,DurHour,DurMin,ArrHour,ArrMin;
 scanf("%d %d %d %d",&DepHour,&DepMin,&DurHour,&DurMin);
 if(DepMin+DurMin>=60)
  {ArrHour=DepHour+DurHour+1;
    ArrMin=DepMin+DurMin-60;}
   else
    {ArrHour=DepHour+DurHour;
    ArrMin=DepMin+DurMin;}
   printf("%d:%d",ArrHour,ArrMin);
 return 0;}

//PascalABC.NET 3.2 сборка 1318

Var 
DepHour,DepMin,DurHour,DurMin,ArrHour,ArrMin:integer;
begin
readln(DepHour,DepMin,DurHour,DurMin);
if DepMin+DurMin>=60 then
 begin
  ArrHour:=DepHour+DurHour+1;
  ArrMin:=DepMin+DurMin-60;
 end
 else
 begin
  ArrHour:=DepHour+DurHour;
  ArrMin:=DepMin+DurMin;
 end;
 write(ArrHour,':',ArrMin);
 end.

Пример ввода:
1 40 12 23
Пример вывода:
14:3
0,0(0 оценок)
Ответ:
КекЛолКарвалол
13.05.2023 13:23
Если Вашу программу исправить, это так будет выглядеть:
var a,b,c,p:real;
begin
writeln('введите размеры треугольника a,b,c');
read(a,b,c);
p:=a+b+c;
if (a=b) and (a=c)then
begin writeln('треугольник равносторонний');
writeln('периметр треугольника',p);
end
else writeln ('треугольник не равносторонний');
end.

А если написать самостоятельно, я бы сделал так:
var
  a,b,c:real;
begin
  Write('Введите размеры треугольника a,b,c: '); Read(a,b,c);
  if (a=b) and (a=c) then
    Writeln('Треугольник равносторонний с периметром ',3*a)
  else Writeln ('Треугольник не равносторонний')
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота