yanakorzh2003
01.06.2020 02:10

Задан массив A[1, 15] случайным образом на отрезке [1, 20]. Составить программу поиска элемента, равного

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
meonder
12.11.2020 06:59
    проверяем значение формулы на концах отрезков, нужный ответ будет при значении  данной формулы "истина" на концах отрезков:
1) [0; 3]
x=0
0∉A + 0∈[ 2;10] +0∈[6;11]≠1   ( данный отрезок не является решением)

2) [3;11]
   x=3
x∉A+3∈[2; 10] + 3∈[6;11]=1
  x=11
x∉A+11∈[2;10]+11∈[6;11]=1
    вывод:  на концах отрезка [3;11] данная формула имеет значение "истина", значит и любая точка этого отрезка даст значение "истина" данной формуле.
        ответ 2)
(аналогично, подставляя концы отрезков 3) и 4) , можно удостовериться, что они не дадут данной формуле значение "истина"  )
0,0(0 оценок)
Ответ:
sasha22114
04.12.2021 14:07
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!
// Не знаю, есть ли какая то разница между векторами и массивами в Паскале, поэтому написал с массивом
begin
var a:=ReadArrInteger('Введите элементы вектора', 20);
Writeln('Сумма положительных элементов -> ', a.Where(t -> t > 0).sum);
Writeln('Сумма отрицательных элементов -> ', a.Where(t -> t < 0).sum);
Writeln('Произведение суммы пложительных чисел на минимальный элемент -> ', a.Where(t -> t > 0).sum * a.Min);
Writeln('Произведение суммы отрицательных чисел на минимальный элемент -> ', a.Where(t -> t > 0).sum * a.Min);
Writeln('Сумма между min и последним элементом вектора -> ', a.Where((v,i)-> i > a.IndexMin).Sum);
a:= a[:15]+a[16:];
Writeln(a);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота