Ульяна3330
05.04.2022 04:01

На си: Заданы массивы чисел Х [0.. n] и Y[0..m]. Написать программу, определить

значение переменной z. Исходные данные и результат напечатать с пояснительным

текстом. Решение задачи оформить с использованием функций. Значения n и m задавать с

клавиатуры, значения элементов массива задавать случайным образом.

В формулах расчета y использованы следующие условные обозначения:

А1(Х) - сумма элементов массива Х;

А2(Х) - сумма положительных элементов массива Х;

А3(Х) - сумма отрицательных элементов массива Х;

А4(Х) - количество нулевых элементов массива Х;

А5(Х) - сумма максимального и минимального элементов массива Х;

А6(Х) - среднее арифметическое значение элементов массива Х;

А7(Х) - произведение абсолютных значений элементов массива Х;

А8(Х) - корень квадратный из суммы положительных элементов массива Х;

А9(Х) - натуральный логарифм из суммы абсолютных значений элементов массива Х;

А10(Х) - сумма корней квадратных из положительных элементов массива Х;

М1(Х) - количество элементов массива Х, значения которых меньше А1;

М2(Х) - количество отрицательных элементов массива Х;

М3(Х) - количество элементов массива Х, значения которых больше А6;

М4(Х) - количество элементов массива Х, значения которых меньше А6;

М5(Х)- количество элементов массива Х, значения которых больше А8.


На си: Заданы массивы чисел Х [0.. n] и Y[0..m]. Написать программу, определитьзначение переменной z

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
svetaH666
29.05.2021 02:50
:D 
Ну го Ничего если  на паскале напишу ? 
uses crt;
var  a:array[1..50] of integer ;i,j,n,x,t,k:integer;b:string;
begin
read(n);     
for i:= 1 to n do     
begin     
a[i]:=random(15);     
write(a[i],' ');     
end;     
writeln;     
for i:= 1 to n-1 do     
for j:= i+1 to n do     
if a[i]> a[j] then begin t:=a[i]; a[i]:=a[j]; a[j]:=t; end;     
for i:= 1 to n do     
write(a[i],' ');     
writeln;     
read(x);     
for i:= 1 to n do     
 if a[i] = x then k:=k+1;     
 str(k,b);     
n:=length(b);     
 if k in  [11..19] then write (k,' раз') else     
 if k = 0 then  write('число ',x,' не встречается ')else     
case b[n] of     
 '0','1','5','6','7','8','9': write (k,' раз');     
 '3','4','2': write (k,' раза') ;     
end;
end.
0,0(0 оценок)
Ответ:
егормай
29.05.2021 02:50
:D 
Ну го Ничего если  на паскале напишу ? 
uses crt;
var  a:array[1..50] of integer ;i,j,n,x,t,k:integer;b:string;
begin
read(n);     
for i:= 1 to n do     
begin     
a[i]:=random(15);     
write(a[i],' ');     
end;     
writeln;     
for i:= 1 to n-1 do     
for j:= i+1 to n do     
if a[i]> a[j] then begin t:=a[i]; a[i]:=a[j]; a[j]:=t; end;     
for i:= 1 to n do     
write(a[i],' ');     
writeln;     
read(x);     
for i:= 1 to n do     
 if a[i] = x then k:=k+1;     
 str(k,b);     
n:=length(b);     
 if k in  [11..19] then write (k,' раз') else     
 if k = 0 then  write('число ',x,' не встречается ')else     
case b[n] of     
 '0','1','5','6','7','8','9': write (k,' раз');     
 '3','4','2': write (k,' раза') ;     
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота