098марина080
22.07.2021 02:53

Составить программу(паскаль) сформировать массив (t кол-во элементов 20) случайных чисел,выбранных на интервале от -10 до +10.вывести кол-во нулевых элементов,сумму элементов кратных 3 и среднее арифметическое всех элементов массива.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Mv0856
14.06.2020 01:18

var t:array[0..19] of byte;

      i,k,l,s:integer;

begin      

 

k:=0;

l:=0;

s:=0;

for i:=0 to 19 do begin

t[i]:=random(21)-10;

write(t[i],'   ');

if t[i]=0 then k:=k+1;

if t[i] mod 3=0 then s:=s+t[i];

l:=l+t[i];

end;

 

write('колво 0  ',k);

write('сумма кратных 3 ',s);

write('средне арефм ',l/20); 

    end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота