Витя - Москва
Боря - Омск
Гриша - Санкт-Петербург
Егор - Киров.
Объяснение:
Известно что Боря жил в одной комнате с мальчиком из Кирова и ни один из этих мальчиков не был в Москве, ни в Санкт-Петербурге, то есть Боря был не из Москвы, не из Питера и не из Кирова, остаётся-Омск.
Гриша играл в одной команде с мальчиком из Москвы, а вечерами к ним заходил мальчик из Кирова, значит, точно знаем, что Гриша был не из Москвы, не из Кирова, остаются Питер и Омск, но мы уже установили, что из Омска был-Боря, получается, что Гриша был из Питера.
Егор и мальчик из Москвы увлекались игрой в шахматы, значит, Егор был точно не из Москвы, и при этом мы знаем, что Омск и Питер уже заняты. Остался Киров У нас остался один город Москва и один мальчик, которого зовут Витя, значит, Витя был из Москвы.
Какой оператор цикла желательно использовать, если известно число повторений тела цикла?
repeat <оператор1, …>until <условие>
while <условие>do <оператор>
for <параметр>:= <начальное значение>to<конечное значение> do<оператор>
2. Используется оператор for i:= -10 to 10 do…
После завершения выполнения тела цикла i = 10
3. Цикл в фрагменте программы
p:=1;
repeat
p:=p*0.1
until p>0.1;
будет исполнен:
1 раз
2 раза
бесконечное число раз
0 раз
3 раза
4. Цикл в фрагменте программы
a:=1;
b:=1;
while a+b<8 do
begin
a:=a+1; b:=b+2
end;
выполнится:
0 раз
3 раза
2 раза
1 раз
бесконечное число раз
5. Какой оператор цикла желательно использовать для записи алгоритмической конструкции, изображённой на схеме?
НЕТ СХЕМЫ. ОТВЕТИТЬ НА ВОПРОС НЕВОЗМОЖНО.
while <условие> do <оператор>
for <параметр>:= <начальное значение> to <конечное значение> do <оператор>
repeat <оператор1, …> until <условие>
6. Какой оператор цикла желательно использовать, если известно условие выхода из цикла?
repeat <оператор1, …> until <условие>
for <параметр>:= <начальное значение> to <конечное значение> do <оператор>
while <условие> do <оператор>
7. Определите, какое значение будет выведено на экран в результате выполнения приведенной ниже последовательности операторов:
a:=1; b:=1;
while a<=32 do a:=a*2; b:=b*a; //Обратите внимание! Нет begin end.
write (b)
32
256
64
128
8. Используется оператор for i:= -5 to 9 do…
При первом выполнении тела цикла i = -5
9. Чему равно значение переменной s после выполнения следующего фрагмента программы
Фрагмента программы нет! Задание решить нельзя!