Ronni05
20.12.2020 22:55

Линейный массив содержит сведения о количестве осадков, выпавших за каждый из 12 месяцев одного года. составить программу, определяющую общее количество осадков за этот год, среднемесячное количество осадков, количество засушливых месяцев (когда количество осадков было меньше 30 мм), самый засушливый месяц года. для turbo pascal.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
NikikitaHyduak
14.06.2020 00:44
Program zadacha;
var
a: array [1..12] of integer;
i, o, k, z, j: integer;
s:real;
begin
writeln('vvedite kolichestvo osadkov');
for I:=1 to 12 do
read(a[I]);
o:=0;
for I:=1 to 12 do
o:=o+a[I];
writeln('obshee kolichestvo osadkov=',o);
s:=o/12;
writeln('srednee kolichestvo=',s:3:2);
k:=0;
for i:=1 to 12 do
if a[I]<30 then k:=k+1;
writeln('kolichestvo zasushlivih=',k);
j:=30;
for I:=1 to 12 do
if a[I] begin
j:=[I];
z:=I;
end;
writeln('samiy zasusliviy mesyac=',z);
readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота