филин2008
10.08.2020 04:02

составить программу в которой 20 элементов массива задаются с рандом и осортировать их по возростанию

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
LidaTetyorkina
23.02.2021 01:49
//PascalABC.Net 3.0, сборка 1064
const
  nn=50;
var
  a:array[1..nn] of integer;
  i,n,imin:integer;
begin
  Write('Введите количество элементов в массиве: '); Read(n);
  Randomize;
  Writeln('Исходный массив');
  imin:=1;
  for i:=1 to n do begin
    a[i]:=Random(51)-25;
    Write(a[i],' ');
    if a[i]<a[imin] then imin:=i;
  end;
  Writeln;
  for i:=imin to n-1 do a[i]:=a[i+1];
  Writeln('Массив-результат');
  for i:=1 to n-1 do Write(a[i],' '); Writeln
end.

Тестовое решение:
Введите количество элементов в массиве: 15
Исходный массив
17 -3 22 18 -13 -5 5 -15 -18 23 17 -2 -20 23 2
Массив-результат
17 -3 22 18 -13 -5 5 -15 -18 23 17 -2 23 2

А это версия для тех, кто думает, что Паскалю пора давно "на свалку":
//PascalABC.Net 3.0, сборка 1064
begin
  var n:=ReadInteger('Введите количество элементов в массиве');
  var a:=SeqRandom(n,-25,25).ToArray();
  Writeln('Исходный массив:',#13#10,a);
  Writeln('Результат:',#13#10,a.Where(x->x<>a.Min));
end.

Тестовое решение:
Введите количество элементов в массиве 15
Исходный массив:
[-10,-15,8,-19,9,21,-22,-11,12,14,2,19,-25,-5,-15]
Результат:
[-10,-15,8,-19,9,21,-22,-11,12,14,2,19,-5,-15]

Можно сравнить понятность кода и его размер как со "школьным" решением, так и с программой на Java, приведенной в предыдущем ответе.
0,0(0 оценок)
Ответ:
sematom
23.02.2021 01:49
//Java
import java.util.ArrayList;

class Main {
public static void main(String[] args) {
ArrayList<Integer> a = new ArrayList();

/**
 * Заполнение
 */
for (int i = 0; i < 50; i++)
a.add(i, new java.util.Random().nextInt(100));

/**
 * Пузырь
 */
for (int i = 0; i < 50; i++)
for (int j = 0; j < 50-i-1; j++)
if (a.get(j) > a.get(j+1)){
int b = a.get(j);
a.set(j, j+1);
a.set(j+1, b);
}

for (int i = 0; i < 50; i++)
System.out.print(a.get(i) + " ");
System.out.println("\n---");

/**
 * Удаляем
 */
a.remove(0);

for (int i = 0; i < 50-1; i++)
System.out.print(a.get(i) + " ");
}
}

Проверка:
1 2 3 4 5 6 7 8 9 10 12 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 96 98
---
2 3 4 5 6 7 8 9 10 12 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 96 98

Так как использовался, само расширяющийся массив, то при удалении, ничего сдвигать не нужно
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота