KsyLisa
04.02.2021 12:14

Stepik 2.1 шаг 4 из 10 Напишите программу, ко­то­рая в по­сле­до­ва­тель­но­сти целых чисел опре­де­ля­ет их сумму и под­счи­ты­ва­ет количество по­ло­жи­тель­ных чётных чисел, не пре­вос­хо­дя­щих 100.

Количество чисел не пре­вы­ша­ет 1000. Введённые числа по мо­ду­лю не пре­вы­ша­ют 30 000.

Формат входных данных
Про­грам­ма по­лу­ча­ет на вход целые числа, ко­ли­че­ство введённых чисел неизвестно, по­сле­до­ва­тель­ность чисел за­кан­чи­ва­ет­ся чис­лом 0 (0 — при­знак окон­ча­ния ввода, не вхо­дит в последовательность).
Формат выходных данных
Про­грам­ма долж­на вы­ве­сти два числа: сумму чисел в последовательности и количество по­ло­жи­тель­ных чётных чисел, не пре­вос­хо­дя­щих 100.

на языке ПИТОН​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Vika20040406
19.05.2020 06:40
Чтобы вставить музыку в презентацию, ЕСТЕСТВЕННО, её нужно сохранить на ваше устройство, а как иначе? Представьте ситуацию, вы хотите приготовить салат, но у вас нет одного ингредиента, вы же не можете взять его из «ниоткуда», его надо либо купить, либо в огороде взять,в общем, что угодно, но оно должно ПРИСУТСТВОВАТЬ у вас.
Тоже самое и с музыкой. Музыка должна быть сохранена на устройство, чтобы использоваться в презентации. И кстати, если эту презентацию переносить на накопительное устройство, то музыку обязательно захватывать тоже.
0,0(0 оценок)
Ответ:
ibraevaira
26.07.2022 12:28
Var i,j,s,k:integer;
begin
s:=0; k:=0;
for i:=1 to 9 do
 for j:=0 to 9 do
  begin
  s:=s+i*100+j*10+i;
  k:=k+1;
  end;
writeln('s = ',s,' k = ',k,' sred = ',s/k:6:2);
end.

Результат:
s = 49500 k = 90 sred = 550.00

Если нужно приложение с формой, то:
помещаете на форме командную кнопку (Button) и статичный текст (StaticText).
В обработчик кнопки добавляете код:
procedure TForm1.Button1Click(Sender: TObject);
var i,j,s,k:integer; s:string;
begin
 s:=0; k:=0;
 for i:=1 to 9 do
  for j:=0 to 9 do
   begin
   s:=s+i*100+j*10+i;
   k:=k+1;
   end;
   s:='s = '+IntToStr(s)+' k = '+IntToStr(k)+' sred = '+FloatToStr(s/k);
  StaticText1.Caption := s;
end;
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота