lolik1162005
11.05.2021 17:28

Составить программу,по которой компьютер запрашивает число,после ввода сообщает отрицательное оно или положительное . Например ,если ввели -6,то выведется фраза "Отрицательное число".​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dianadiadyshyn
06.03.2022 03:18
1. Для цикла For

var
  x,n,p:longint;
  i:integer;
begin
  readln (x,n);
  p:=1;
  for i := 1 to N do
    p:=p*x;
  writeln(x,' в степени ',n,' равно ',p );
end.

2. Для цикла While
var
  x,n,p:longint;
  i:integer;
begin
  readln (x,n);
  p:=1;
  i:=1;
  while i<=n do begin
    p:=p*x;
    i:=i+1;
  end;
  writeln(x,' в степени ',n,' равно ',p );
end.

3. Для цикла Repeat

var
  x,n,p:longint;
  i:integer;
begin
  readln (x,n);
  p:=1;
  i:=1;
  repeat
    p:=p*x;
    i:=i+1;
  until i>n;
  writeln(x,' в степени ',n,' равно ',p );
end.
0,0(0 оценок)
Ответ:
Давидычь
09.05.2023 02:33

Объяснение:

Микрофо́нный эффе́кт — нежелательное явление, при котором некоторая часть электрической цепи воспринимает звуковые колебания и вибрацию подобно микрофону. Является источником помех. Чаще всего возникает при изменении ёмкости, особенно в высокочастотных цепях, где даже незначительные колебания плохо закреплённых деталей могут существенно повлиять на параметры прохождения основного сигнала. Также источником этого явления могут быть:

Электронные лампы, при колебаниях электродов меняющие свои параметры.

В керамических конденсаторах нередко применяется диэлектрик, который обладает пьезоэффектом.

Воспроизводящая магнитная головка магнитофона — наличие паразитного постоянного магнитного поля от окружающих деталей лентопротяжного механизма приводит к тому, что вибрация обмотки магнитной головки возбуждает в ней дополнительную ЭДС.

Головка звукоснимателя электрофона может воспринимать вибрации, создаваемые электродвигателем ЭПУ.

Электромагнитный звукосниматель электрогитары может воспринимать вибрации корпуса инструмента и колебания воздуха, что может привести к возникновению лишних призвуков и нежелательной акустической обратной связи со звукоусиливающей аппаратурой.

Плохой электрический контакт в разъёмах.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота