VeronaKotik
14.01.2021 11:08

Написать программу на паскале: "если введенное целое число является трехзначным, то удалить из него среднюю цифру; если число двухзначное, то удвоить крайние цифры; иначе – выдать сообщение «ошибка ввода»."

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
zhuniorneimar486
14.06.2020 00:22

program z1;
uses crt;
var n:integer;
begin
writeln(''вв число');
readln(n);
if n>999 then writeln('ошибка ввода') else
if n>100 then writeln((n div 100)*10+n mod 10 ) else
writelnn div 10)*2)*10)+((n mod 10)*2));
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота