mihailova1999
08.03.2022 19:52

Написать программу на паскале если данное число х меньше нуля, то z присвоить значение большего из 2 чисел х и у, иначе z присвойте значение полсуммы этих чисел.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
юююю20
13.06.2020 23:52

  Program Z;

Uses Crt;

var x,y,z:real;

begin

    clrscr;

    write('Введите х: ');

    readln(x);

    write('Введите y: ');

    readln(y);

    if (x<0)  and (x>y) then z:=x;

    if (x<0)   and (x<y) then z:=y;        

 

    if (x>=0) then z:=(x+y)/2;

    writeln('z=',z);

   readkey;

 

end. 

 

 

 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота