dashaR06032006
04.11.2020 21:24

Программа в Pascal Рассматривается множество целых чисел, принадлежащих числовому отрезку [1016; 7937], которые делятся на 3 и не делятся на 7, 17, 19, 27. Найдите количество таких чисел и медиану этих чисел. В ответе запишите два целых числа: сначала количество, затем медиану этих чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Владислава3188125
16.01.2021 11:21
1)uses crt;
var i,j,n,ans:integer;
begin
read(n);
for i:=1 to 9 do
for j:=0 to 9 do
if i+j=n then
ans:=ans+1;
writeln(ans);
end.
2)
uses crt;
var i,n:integer;
x:array[1..100] of integer;
begin
writeln('Введите количество x и значения: ');
read(n);
for i:=1 to n do
read(x[i]);
writeln('x  y');
for i:=1 to n do
writeln(x[i],'  ',x[i]*x[i]+3);
end.
3.
uses crt;
var i:integer;
begin
for i:=1 to 5 do
write(i*i*i,' ');
end.
4.
uses crt;
var i,n,sum:real;
begin
writeln('Введите N:');
read(n);
i:=3;
while i<=n do
begin
sum:=sum+1/i;
i:=i+3;
end;
writeln(sum);
end.
5.
uses crt;
var j,i,n,sum:integer;
a:array[1..100] of integer;
begin
writeln('Введите количество чисел и сами числа:');
read(n);
for i:=1 to n do
begin
sum:=0;
read(a[i]);
for j:=1 to length(inttostr(a[i])) do
sum:=sum+strtoint(inttostr(a[i])[j]);
if sum mod 3 = 0 then
write(a[i],' ');
end;
end.
6.a)uses crt;
var n:string;
begin
read(n);
writeln(max(strtoint(n[1]),strtoint(n[2])));
end.
б)
uses crt;
var n:string;
begin
read(n);
writeln(max(max(strtoint(n[1]),strtoint(n[2])),strtoint(n[3])));
end.
0,0(0 оценок)
Ответ:
Настя200101
04.05.2023 02:21

Решение перебором АДЛТДТАТ

Объяснение:

Для начала можно понять, что первая точка и продолжение подходит только для буквы А и в итоге остаётся: -...-..--..-.--, дальше у нас 2 варианта:

1) АД.-..--..-.-- >> 1 - АДА..--..-.-- 2 - АДЛ--..-.--

2)АТ...-..--..-.-- >> АТЖ..--..-.--

Продолжаем перебирать:

1)  АДА..--..-.--  больше нельзя продолжить т.к букв из 2 точек вначале нету.

2) АДЛ--..-.--  >>   АДЛТ-..-.--  >> 1)АДЛТД-.-- 2)АДЛТТ..-.--

3) АТЖ..--..-.--  >> нельзя продолжить из за двух точек.

Продолжаем:

1)АДЛТД-.-- >> АДЛТДТАТ - это ответ

2)АДЛТТ..-.-- нельзя продолжить из за двух точек.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота