03Faridm1
20.11.2020 10:27

Питон Напишите программу, которая принимает на вход числа и , написанные в одной строчке через пробел, и решает линейное уравнение вида +=0 . Если корней бесконечно много, программа должна вывести INF, если корней нет, программа должна вывести No roots. Если корень один и он нецелый, то надо его вывести с точностью 6 знаков после запятой.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
elena111104
27.01.2023 15:20

Чтение Задание 1. Прочитай текст. Английский плюс CD-ROM: блок 9 более высокий тест. Торговый центр Mall of America-это действительно большой торговый центр в США. Это больше, чем любой торговый центр в Европе! Расстояние до торгового центра составляет 390 000 метров?. Он имеет семь этажей и 52 Шора. Здесь четырнадцать кинотеатров и двадцать ресторанов, в торговом центре нет ни одной гостиницы, зато есть железнодорожный вокзал и автовокзал. В городе Миннеаполис есть несколько отелей. Город находится примерно в тридцати минутах езды от торгового центра. Меня зовут Бет, и моя семья живет в Миннеаполисе. Мы очень любим ходить по магазинам, и торговый центр-наше любимое место! Пишите правильно или неправильно: 1. Торговый центр Америки огромен 2. Торговый центр Америки находится в США 3. 3. На одном этаже расположены 52 магазина. 4. В торговом центре " 5 " есть места для фильмов. Бет не очень любит ходить по магазинам ответьте на этот во Насколько велик торговый центр Америки? 7. Сколько времени нужно, чтобы добраться от Миннеаполиса до торгового центра? письменные задания. Выберите одну из следующих тем. Йо вы должны: * высказать свое мнение по теме. Соедините свои идеи в один абзац. Используйте правильную форму модальных глаголов: нельзя, нужно, должно. Используйте пунктуацию соответствующим образом. Тема 1. Наш район какое место вы хотели бы посетить в своем соседстве? Почему тебе нравится это место? Какие достопримечательности вы хотели бы там увидеть? Вы бы хотели жить в этом месте? Почему? Тема 2. Транспорт какие виды транспорта вы знаете? Кто из них более опасен? Почему ты так думаешь? Разве это вредит жизни людей? Почему? Какой вид транспорта вы предпочитаете? Почему?

0,0(0 оценок)
Ответ:
ilyassovaalina235393
30.11.2021 11:48
Var a: array [1 .. 10] of integer;
  i, Count, C, tmpLast, tmpFirst: integer;
begin
  write('Введите число C: ');
  readln(C);
  writeln;
  for i := 1 to 10 do
  begin
    write('a[', i, '] = ');
    readln(a[i]);
    if a[i] = C then
    begin
      Count := Count + 1;
      tmpLast := i;
    end;
  end;
  writeln;
  if (Count = 0) then writeln('В массиве нет числа равное С')
  else
  begin
    writeln('В массиве нашлось число, равное С');
    if (Count = 1) then
      writeln('Первое и единственное число в позиции a[', tmpLast, ']')
    else
    begin
      i := 0;
      repeat
        i := i + 1;
        tmpFirst := i;
      until (a[i] = C);
      writeln('Первое такое число a[', tmpFirst, ']');
      writeln('Последнее такое число a[', tmpLast, ']');
    end;
  end;
  readln;
end.

Ввести число с. определить, есть ли в массиве элемент, равный с. найти • номер первого такого элемен
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота