Мплисс
19.05.2023 22:43

1. написать программу, которая подсчитывает количество четных чисел в массиве целых чисел. количество элементов массива равно n.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Alyona2022
13.06.2020 22:09

Решение на языке C:

 

#include <stdio.h>

int func(int *array, int n)
{
  int result = 0;
  for (int i = 0; i < n; i++) {
    if (array[i] % 2 == 0) {
      result++;
    }
  }
  return result;
}

int main(int argc, char *argv)
{
  int array[] = {1, 2 , 3 , 4 , 5 , 6, 7, 46};
  printf("%d", func(array, 8));
  return 0;
}

0,0(0 оценок)
Ответ:
FUKCтическая
13.06.2020 22:09

// Язык Паскаль 

Program Massiv;

Uses Crt;

const n=10; // Нужно больше сам подставишь нужное число

 

 var a:array[1..n] of integer;

        i,c:integer;

begin

     clrscr;

     write('Введите элементы массива: ');

     c:=0;  

     for i:=1 to n do

        begin  

            readln(a[i]); 

 

            if (a[i] mod 2)=0 then c:=c+1; 

 

        end; 

 

writeln;

write('Исходный массив:');

 for i:=1 to n do write(a[i],'  ');

writeln('Количество чётных элементов: ',c); 

   readkey;

 

end. 

 

 

 

 

 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота