машазайка1
03.09.2020 14:39

(PASCAL)Напишите программу для решения следующей задачи. Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите самую низкую температуру за время наблюдения. Если температура опускалась ниже –15 градусов, выведите YES, иначе выведите NO. Программа получает на вход количество дней, в течение которых проводилось измерение температуры N (1 ≤ N ≤ 31), затем для каждого дня вводится температура. Пример работы программы:

Входные данные

4

–5

12

–2

8

Выходные данные

–5

NO

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ATAT1
21.01.2021 17:04

var x:integer;

n: array[1..31] of integer;

begin

 for var i:=1 to 31 do

 begin

   write('Введите температуру ',i,' дня: '); readln(n[i]);

   if n[i]<x then x:=n[i];

 end;

 writeln; writeln('Минимальная тепература: ',x);

 if x<-15 then writeln('YES') else writeln('NO');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота