замёрзший
27.02.2022 18:50

7 вариант, написать программу, ​


7 вариант, написать программу, ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
юлия20082
09.09.2021 00:37

a = int(input())

for i in range(a):

 b = input()

 c = 0

 d = True

 e = 0

 f = False

 g = False

 h = '\''

 for j in b:

   if j == '#' and not f:

     g = True

     break

   elif j != ' ':

     if d:

       print(' ' * c, end='')

     elif c > 0:

       print(' ', end='')

     c = 0

     print(j, end='')

     if(j == '\"' or j == '\'') and e % 2 == 0:

       if f and j == h:

         f = False

       else:

         f = True

         h = j

     if f:

       d = True

     else:

       d = False

     if j == '\\':

       e += 1

     else:

       e = 0

   else:

     c += 1

   r = j == ' '

if g and c > 1:

 print(' ', end='')

if i < a - 1:

 print()

1

Объяснение:

0,0(0 оценок)
Ответ:
Ksenia20066kislova
20.08.2022 16:47

var

 x, y, t, c, n, k: integer;

 a: array [1..10] of integer;

begin

 for t := 1 to 10 do

   a[t] := 0;

 read(x, y);

 t := x;

 while (t <> 0) do

 begin

   c += 1;

   t := t div 10;

 end;

 k := 1;

 for t := 1 to c do

   k *= 10;

 while (x <> 0) do

 begin

   n := y;

   t := x div k;

   while (n <> 0) do

   begin

     c := n mod 10;

     n := n div 10;

     if (c = t) and (a[c + 1] = 0) then

     begin

       write(t, ' ');

       a[c + 1] += 1;

       break;

     end;

   end;

   x := x mod k;

   k := k div 10;

 end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота