vanuaevstifeev
22.05.2023 21:53

Тест по теме «Язык программирования Паскаль»

1. Для отделения операторов друг от друга в языке Паскаль используют:
а) пробел; б) двоеточие; в) запятую; г) точку с запятой.

2. Из предложенных заголовков программы правильным является:
а) Program сумма; в) programm сумма;
б) programm summa; г) program summa.

3. Для вывода результатов в языке программирования Паскаль используют ключевое слово:
а) VAR; б) READ; в) BEGIN; г) WRITE.

4. Квадратный корень числа вычисляет функция:
а) SQRT (X); б) SQR (X); в) ABS (X); г) INT (X).

5. Конечное значение переменной У в результате выполнения следующих действий:
У:=5;
Х:=2;
У:=(У-2*Х)/2+Х
будет равно:
а) 0,5; б) 2; в) 2,5; г) 5.

6. В результате выполнения программы

program my_klass;
begin
write (25/2,5*2);
writeln (‘улыбок’);
end.

мы увидим на экране:
а) 5 улыбок; в) 5
улыбок;
б) 25 улыбок; г) 25
улыбок.

7. В данном фрагменте программы

program error;
begin
summa:=25-14;
end.

ошибкой считают:
а) некорректное имя программы;
б) длинное имя переменной;
в) не определенное имя переменной;
г) запись арифметического выражения.

8. Значения одномерного массива задаются с цикла:
for i:=1 to 5 do B[i]:= 5+i;
В результате значение В[3] будет равно:
а) 9; б) 8; в) 7; г) 6.

9.

for i:=1 to 10 do begin
if a[i]>0 then a[i]:=a[i]/2
else a[i]:=i;
end;

произойдет следующее:
а) положительные значения элементов массива увеличатся вдвое, а отрицательные заменятся значениями индекса;
б) положительные значения элементов массива уменьшатся вдвое, а отрицательные заменятся значениями индекса;
в) отрицательные значения элементов массива увеличатся вдвое, а положительные заменятся значениями индекса;
г) отрицательные значения элементов массива уменьшатся вдвое, а положительные заменятся значениями индекса.

10. В результате выполнения фрагмента программы

writeln (‘Новый массив’);
for i:=1 to 20 writeln (a[i]);
end.

произойдет следующее:
а) сформируется новый массив;
б) новый массив распечатается;
в) распечатаются только индексы;
г) сформируются только индексы.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
dimanchik0108
20.05.2022 11:52
Var   i, n:integer; b:array[1..3] of integer;begin    write('Type integer: ');    readln(n);    if n<0 then        n:=-n; // уничтожение знака числа     repeat    i:= i + 1;        b[i] := (n mod 10); // вывод последней цифры числа        n:= n div 10; // удаление последней цифры числа    until n=0;    if b[3] > b[2] thenwriteln('Цифра сотен больше десятков ',b[3] - b[2])elsewriteln('Цифра сотен меньше десятков ',b[2] - b[3]);if b[2] > b[1] thenwriteln('Цифра десятков больше единиц ',b[2] - b[1])elsewriteln('Цифра десятков меньше единиц ',b[1] - b[2]);end.
0,0(0 оценок)
Ответ:
egorkorotenko
21.11.2020 12:01
Если система пятеричная, в ней 5 цифр - от 0 до 4. Но ноль не является натуральным числом, поэтому начнем с единицы.
Итак, 1, 2, 3, 4.
Каждое число получается увеличением значения своего предшественника на единицу.
4+1 = 5, это мы знаем, но цифры 5 в этой системе нет. Так же, как в нашей десятичной системе нет цифры 10 - последняя в ней девятка. А 10 - это сброс разряда в ноль и перенос единички в следующий разряд. Потом будет 1, 2, 3, ..9, и снова перенос 1 со сбросом в 0.
В пятиричной системе - то же самое. После 4 идет сброс в ноль и единичка в старший разряд. Поэтому получаются числа
10, 11, 12, 13, 14
Далее - сброс, плюс единичка в старший, и получим 20.
Все, получено 10 чисел.
Окончательно: 1, 2, 3, 4, 10, 11, 12, 13, 14, 20
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота