NEO178
09.12.2021 22:46

составить программу по информатике! Город Волгоград несколько раз менял свое название
Составить программу на языке программирования Pascal, которая на введенную дату выдает название города. Если:
с 1589 – 1925г. –Царицын
с 1925 – 1961 г. Сталинград
с 1961г. – Волгоград

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Subina00
22.05.2022 14:16

Вот код:

a = list(map(int, input().split()))

b = []

c = []

def schot(a):

   count = 0

   for i in range(5):

       for j in a:

           if j == 2 * i:

               count += 1

   if count != 1:

       return True

   else:

       return False

while schot(a):

   b.append(max(a))

   a.pop(a.index(max(a)))

for i in range(5):

   for j in a:

       if j == 2 * i:

           c.append(j)

           a.pop(a.index(j))

           break

while a != []:

   b.append(max(a))

   a.pop(a.index(max(a)))

b.append(c[0])

for i in b:

   print(i, end="")

Объяснение:

Его смысл в том что есть функция проверяющая кол-во четных цифр в массиве всех цифр а и потом если там больше одной четной цифры то он берет наибольшую цифру и ставит ее на последнее место в массиве б, ну а если осталась одна четная цифра то код убирает эту цифру и продолжает набор цифр без нее и под конец закидывает ее чтобы получилось четное число :)))

P.S. тоже в Сириус?))

0,0(0 оценок)
Ответ:
AnyRam
26.07.2022 12:54

2) Вопрос не понял, но думаю правильно ответил:

var a,b,c,d :int64;

begin

readln(a);

b := a -1;//число до  

c := a +1;//число след.

writeln('Число до: ',b,' Число след.: ',c);

end.

3)

var a,b,c,d :int64;

begin

readln(a);//Кол-во учеников

readln(b);//Кол-во яблок

c := b div a;//Яблок каждому ученику

d := b - (a * c);//Яблок в корзине  

writeln('Яблок каждому: ',c,' Яблок осталось в корзине: ',d);

end.

4)

var a,b,c,d:int64;

begin

readln(a);//Число

b := a mod 10;//остаток от деления

c := a div 10;//деление без остатка

d := c mod 10;//остаток от деления

writeln('При последнее число: ',d,' Последнее число: ',b);

end.

5)

var a,b,c,d:int64;

begin

readln(a);//Автобус за день  

readln(b);//Кол-во дней

c := a * b;

writeln('Автобус проехал: ',c,' (км)');

end.

6)

var a,b,c,d:int64;

begin

readln(a);//Путь муравья

b:= a div 1000;//м

c:= (a - (b*1000)) div 10;

//см

d:= a - (b*1000+c*10);

//мм

writeln('Путь муравья: ',b, ' (м) ',c,' (см) ',d,' (мм)');

end.

7)

var a,b,c,d:int64;

begin

readln(a);//Грань куба

b := a*a*a ;

writeln('Объем куба: ',b, ' м^3');

end.

8)

var a,b,c,d,g:real;

begin

readln(a,c,d,b);//Числа

g:=(a+c+d+b) / 4 ;

writeln('Cреднее арифметическое: ', g);

end.

9)

var a,b,c,d:real;

begin

readln(a,b,c);//Учеников в кадом классе

d:= (a+b+c)/ 2;

writeln('Кол-во парт для 3 классов: ', d);

end.

Объяснение:Все программы написаны на Pascal.

Капец много задач за 5б)))

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота