Cru555her
22.02.2021 18:53

Написать программу пересчета расстояния из верст в километры (1 верста равняется 1066,8 м). Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). Пересчет расстояния из верст в километры.
Введите расстояние в верстах - 100
100 верст(а/ы) – это 106.68 км.
Нужна блок-схема для этого кода

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Asel272727
11.07.2022 14:04

1)

var

  a, b, s : real;

begin

  read (a, b);

  s := a * b;

  write (s:10:4);

end.

 

2)

var

  a, b, c, k : integer;

begin

  read (a, b, c);

  k := 0;

  if a > 0 then inc (k);

  if b > 0 then inc (k);

  if c > 0 then inc (k);

  writeln (k);

end.

 

3)

var

  a : integer;

begin

  read (a);

  writeln ((a mod 10) * (a mod 100 div 10) * (a div 100 mod 10) * (a div 1000));

end.

 

4)

var

  c, n : integer;

begin

  read (n);

  c := 0;

  repeat

    inc (c);

    n := n div 10;

  until n = 0;

  writeln (c);

end.

 

5)

var

  n, sum, i : integer;

begin

  read (n);

  sum := 0;

  for i := 1 to n do

    sum := sum + i;

  writeln (sum);

end.

 

6)

var

  d, n, k : integer;

begin

  read (n, k);

  d := 0;

  while n >= k do

  begin

    d := d + 1;

    n := n - k;

  end;

  writeln ('n div k = ', d);

  writeln ('n mod k = ', n);

end.

 

7)

var

  n, sum, i, tmp : integer;

begin

  read (n);

  sum := 0;

  for i := 1 to n do

  begin

    read (tmp);

    sum := sum + tmp;

  end;

  writeln (sum / n);

end.

 

8)

var

  i, n, s : integer;

  a : array [1..1000] of integer;

begin

  s := 2;

  read (n);

  for i := 1 to n do

  begin

    a[i] := s;

    s := s + 2 * i + 1;

  end;

  for i := 1 to n do write (a[i], ' ');

end.

 

9)

var

  n, i, count, tmp : integer;

begin

  read (n);

  count := 0;

  for i := 1 to n do

  begin

    read (tmp);

    if tmp < 0 then inc (count);

  end;

  writeln (count);

end.

 

10)

var

  n, i, j : integer;

begin

  read (n);

  for i := 1 to n do

  begin

    for j := 1 to i do

      write ('*');

    writeln;

  end;

end.

 

11) //Не понял, как заполняется массив? Тут рандом

var

  a : array [1..1000] of integer;

  i, n : integer;

begin

  read (n);

  for i := 1 to n do

    a[i] := trunc (random (1000)) - 500;

  for i := 1 to n do

    if a[i] > 0 then a[i] := a[i] * (-1)

   else if a[i] < 0 then a[i] := sqr (a[i]);

  for i := 1 to n do

    write (a[i], ' ');

end.

 

12)

var

  n, i, count : integer;

begin

  read (n);

  count := 0;

  for i := 1 to n do

    if n mod i = 0 then inc (count);

  writeln (count);

end.

 

  

0,0(0 оценок)
Ответ:
sweta2012
11.07.2022 14:04
1) program fagasg;
var a,b,c,d: integer;
begin
Writeln('Введите первое число');
readln(a);
Writeln('Введите второе число');
readln(b);
Writeln('Введите третье число');
readln(c);
d:=0;
If a>0 then d:=d+1;
If b>0 then d:=d+1;
If c>0 then d:=d+1;
Writeln('Количество положительных чисел:',d);
end.
2) program gsggdfd;
var n,s,i: integer;
begin
writeln('Введите n');
readln(n);
s:=0;
For i:=1 to n do 
S:=s+i;
Writeln('Сумма последовательности равна:',s);
end.
3)Program afsdgf;
var A: Array[1..100] of integer;   
i,h,s,l: integer;
begin 
Writeln('ведите размер массива'); 
readln(h); 
s:=1; 
l:=1; 
For i:=1 to h do   
begin     
A[i]:=s+l;     
s:=s+2;     
writeln(A[i]);     
l:=A[i];   
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота