saddddddd03
16.04.2022 19:13

Несложная программа на python! Написать программу которая в каждую новую строку выводит новое число за логикой: 0+1-2+3-4+5-6+7-8+9-10 (результат каждой новой операции должен выводится в новую строку). Думаю всё понятно, если есть вопросы - спрашивайте.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
StefanSalvatori
21.01.2021 01:17

s = 0

for i in range(1,12):

   print(0,end=" ")

   for j in range(1,i):

       if j % 2 == 0:

           print('-',j,end=" ")

           s -= j

       else:

           print('+',j,end=" ")

           s += j

   print('=', s)

   s = 0

   print()

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота