NightyMigly
28.09.2022 15:32

№1. представить фрагмент алгоритма в виде блок-схемы. составить программу, соответствующую данной блок-схеме.

a: = 18

b: = 10

a: = b - a/3

b: = 12/a*2

№2.

представить фрагмент алгоритма в виде блок-схемы. составить программу, соответствующую данной блок-схеме.

a: =3

b: =10

a: =b - 24/a

b: =12/a*3

№ 3. представить фрагмент алгоритма в виде блок-схемы. составить программу, соответствующую данной блок-схеме.

a: =50

b: =33

a: =(b-11)/2*7

b: =2*(a-b)+3*(a+b)

№ 4. представить фрагмент алгоритма в виде блок-схемы. составить программу, соответствующую данной блок-схеме.

a: =24

b: =12

a: =a*b/32

b: =8*a+4*b

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nastyankazau112
21.04.2022 06:15
#include <iostream>

using namespace std;

int gcd(int a, int b);

int main()
{
    freopen("input.txt", "r", stdin);
    freopen("output.txt", "w", stdout);
   
    int n;
   
    cin >> n;
   
    for (int i = 0; i < n; ++i)
    {
        int a, b, c, d;
       
        scanf("%d/%d+%d/%d=", &a, &b, &c, &d);
       
        int num = a * d + b * c;
        int den = b * d;
       
        int cur_gcd = gcd(num, den);
       
        num /= cur_gcd;
        den /= cur_gcd;
       
        cout << num;
        if(den != 1)
            cout << '/' << den;
        cout << endl;
    }
   
    fclose(stdin);
    fclose(stdout);
    return 0;
}

int gcd(int a, int b)
{
    if(a == 0)
        return b;
    return gcd(b % a, a);
}
0,0(0 оценок)
Ответ:
дитус
01.02.2022 01:01
Под блокнотом подразумевается стандартный Windows Notepad. Он прост как дважды два, и таким и задумывался. Предназначен для просмотра и возможно редактирования простых текстовых файлов(не документов, форматирование не изменяется), например .txt, .xml, .html и тд
Им можно открыть и посмотреть текстовое представление любого файла, хотя большие файлы он не откроет (зависнет или упадет) и может иметь проблемы с кодировками.
Имеет простейшие функции типа поиск, замена, переход. А так же открыть и сохранить файл.

Если часто приходится иметь дело с текстовыми файлами предназначеными в первую очередь для чтенье компьютером типа программных кодов, скриптов и тд, то рекомендуется использовать специализированные блокноты типа Notepad++, Sublime Text, Vim, Akelpad и тд

MSO Word предназначен для создания, просмотра, редактирования текстовых документов (не просто текстовых файлов) предназначеных в первую очередь для просмотра людьми. Потому очень много уделяется внимания форматированию текста, можно добавлять всякие рисунки, таблички и прочее и прочее
Можно редактировать и простые текстовые файлы, но это не удобно
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота