zzizziz
22.10.2022 21:15

Написать программу вычисления произведений в паскаль 2*4*6**(2n). решить

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nifirazifira
13.06.2020 19:07

var
N, Y, I: Integer;
begin
  ReadLn(N); Y := 1; I := 0;
  repeat
    Inc(I);
    Y := Y * 2 * I;
  until I = N;
  WriteLn(Y);
  ReadLn;
end.

0,0(0 оценок)
Ответ:
Master2111
13.06.2020 19:07

через рекурсию

 

var

function Product(N: Integer): Integer;

begin

if N = 1then

begin

Product := 2;

Exit;

end;

Product := 2 * N * Product(N - 1);

end;

 

 

var

N: Integer;

begin

ReadLn(N);

WriteLn(Product(N));

ReadLn;

end.

 

без рекурсии

 

N, Y, I: Integer;

 

begin

ReadLn(N); Y := 1; I := 0;

repeat

Inc(I);

Y := Y * 2 * I;

until I = N;

WriteLn(Y);

ReadLn;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота