deneleslamov2
15.05.2020 04:46

ПРОГРАММУ В ПАСКАЛЕ И БЛОК-СХЕМУ Дан массив, содержащий 20 положительных целых чисел, не превышающих 30 000. Необходимо найти в этом массиве количество элементов, которые кратны 3, а их десятичная запись заканчивается цифрой 1, и заменить каждый из таких элементов на это количество. Напишите программу для решения этой задачи. В качестве результата программа должна вывести изменённый массив, по одному элементу в строке. Например, для исходного массива из 5 элементов
15 71 21 111 41
программа должна вывести (по одному числу в строке) числа
15 71 2 2 41.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Наташа151515
23.12.2020 23:04

Объяснение:

Колонна, состоящая из тринадцати роботов, движется со скоростью 4 см/с. Когда первый робот колонны поравнялся с роботом-инспектором, то робот – инспектор поехал вдоль колонны со скоростью 60 дм/мин, а достигнув её конца, развернулся и вернулся к первому роботу в колонне. Скорость колонны и робота-инспектора постоянны. Длина колонны роботов равна 2 м 10 см. Определите, какой путь проедет робот-инспектор, пока он снова нагонит первого робота в колонне. Временем на разворот можно пренебречь. ответ дайте в дециметрах. В ответ запишите только число.

0,0(0 оценок)
Ответ:
13xaxa13
06.03.2022 16:30
#include "iostream" using namespace std; int main(){ int secound =0; int hh =0; int mm =0; int ss =0; int ch[5]; cin >> secound; hh = secound / 3600; mm = secound/60 - hh * 60; ss = secound - hh*3600 - mm *60 ; if(hh >=24){ int b = hh / 24; hh = hh - 24 *b; } ch[0] = hh; if(mm< 10){ ch[1] =0; ch[2] = ss; }else ch[1] = mm / 10; ch[2] = mm - mm / 10 * 10; if(ss< 10){ ch[3] = 0; ch[4] = ss; } else ch[3] = ss /10; ch[4] = ss - ss / 10 * 10; cout << ch[0] << ':' << ch[1] <
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота