Shkolnikt
17.02.2023 23:00

Впрограмме паскаль составить программу, выводящую на экран ряд чисел фибоначчи. фибоначчи числа, элементы числовой возвратной последовательности 1, 1, 2, 3, 5, (ряда фибоначчи), в которых каждый последующий член равен сумме двух предыдущих.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Nikart25
13.06.2020 16:54

Program Fibonacci;

Uses Crt;

var  i,n:integer;

 {Итерационный метод вычисления чисел Фибоначчи}

function fib_it(n:integer):integer;

var a,b,c,i:integer;

begin

     a:=1;b:=1;

     if (n=1) or (n=2) then  fib_it:=1

        else    begin

                        for i:=3 to n do 

                                begin

                                    c:=a+b;

                                     a:=b;  

 

                                      b:=c; 

                                end;      

 

                         fib_it:=c;

                    end;     

 

 end;

 

    

 

{main program}

begin

     clrscr;

 

     write('Введите n: ');

      readln(n);

 

      for i:=1 to n do write(fib_it(i),'   '); 

 

      readkey;

 

end. 

 

 

 

 

 

 

 

 

 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота