khadija7
07.03.2020 06:43

Написать программу для трех целочисленных переменных с минимум 6 арифметическими операторами.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kotyaraasm
19.01.2020 20:04

1)Паскаль — язык структурного программирования. Это означает, что для написания программы, необходимо предварительно составить алгоритм ее решения для компьютера. Синтаксисом предусмотрена определенная структура программы на языке

2)program test;

const

e=2.71828;

var

z, x, y: real;

begin

write ('Введите значение х: ');

read (x);

write ('Введите значение y: ');

read (y);

if sqrt(x) + y > 10 then

z := sin(4*x*y)

else if sqrt(x) + y < 10 then

z := (-1 * x) + 2 * y

else z:= x-e;

write ('Функция z = ',z);

end.

Объяснение:

0,0(0 оценок)
Ответ:
izmoksi
19.01.2020 20:04

// Задание 2:

var x, y, z: real;

begin

 Write('Введите x и y через пробел'); ReadLn(x, y);

 if (x + y) > 0 then z := sin(2 * x)

   else if (x + y) < 0 then z := 5 * x * y

     else z := 0;

 WriteLn('z(', x, ', ', y, ') = ', z:0:3);

end.

Объяснение:

Задание 1:

Один из самых популярных языков программирования высокого уровня - язык Паскаль (англ. Philips Automatic Sequence Calculator) был разработан швейцарским ученым Никлаусом Виртом в 1969 году как учебный язык, но спустя некоторое время приобрел популярность как отличный инструмент для решения серьезных задач. Программирование на Паскале обеспечивает высокую надежность программ. Программы на Паскале понятны любому программисту и в то же время они легко транслируются в эффективные машинные коды. Паскаль, наряду с Бейсиком, считается также учебным языком; он принят во многих учебных заведениях как базовый язык для изучения программирования. Так, в США с 1983 года Паскаль введен в учебные курсы всех средних школ для учащихся, специализирующихся в области информатики.

По мере своего развития язык Паскаль постоянно совершенствовался и приобретал новые свойства.

Структура простой программы на языке Паскаль включает в себя:

а) название программы, начинающееся с зарезервированного слова program и имени, состоящего из букв латинского алфавита и цифр. Турбо-Паскаль позволяет опускать объявление program, поэтому данная строка является необязательной. Однако использование слова program является признаком хорошего стиля программирования. Кстати, Среда программирования автоматически присваивает имя, идущее за словом program, файлу с исходным текстом (первые 8 символов);

б) определение меток, начинающееся с зарезервированного слова Label и перечисления через запятую используемых в программе меток, представляющих собой любые цифры от 1 до 9999 или символьные имена;

в) определение констант, начинающееся с зарезервированного слова Const и перечисления используемых в программе констант с присвоенными им именами, знаками = и их значениями и отделяемыми друг от друга точкой с запятой. Типизированные константы также объявляются после слова const, но имена через двоеточие связываются с типом, и лишь потом ставится знак равенства, и указываются значения. В связи с этим секция «const» может повторяться после секции type;

г) определение типов, начинающееся с зарезервированного слова Type и состоящее из перечисления через точку с запятой имен типов, вводимых пользователем, с пояснением через знак равенства (=), от каких базовых типов и как они происходят;

д) описание переменных, начинающееся с зарезервированного слова Var и перечисления используемых в программе переменных с указанием их типа. При этом имена переменных одного и того же типа, могут перечисляться через запятую, с указанием в конце записи после двоеточия их типа, а имена переменных разных типов описываются отдельно и отделяются друг от друга точкой с запятой. В языке Турбо-Паскаль все используемые в программе переменные должны быть объявлены. Это значит, что, во-первых, в начале каждой программы Вы должны привести список всех используемых переменных, а во-вторых, указать тип каждой из них;

е) описание процедур и функций, начинающихся с зарезервированного слова Procedure и имени процедуры или с зарезервированного слова Function и имени функции. В раздел описания каждой процедуры и функции могут входить все перечисленные выше разделы, а также раздел операторов, составляющий непосредственно сами процедуры и функции;

ж) раздел операторов, начинающийся с зарезервированного слова begin и кончающийся зарезервированным словом end и включающий в себя непосредственно весь процесс вычислений. Зарезервированные слова begin и end отмечают начало и конец программы. Они применяются также для того, чтобы объединить несколько операторов программы в составной оператор или “блок” (подробнее о составном операторе см. в теме № 2). После последнего слова end в программе ставится точка, указывающая на ее конец. При этом все, что набрано после слова end с точкой (end.), компилятором игнорируется.

Порядок разделов описаний может быть любым. Разделы друг от друга отделяются точкой с запятой. Раздел операторов является основным в программе. Все другие разделы, кроме раздела операторов могут отсутствовать. Операторы друг от друга отделяются точкой с запятой. В конце раздела операторов после ключевого слова end обязательно ставится точка, которая является признаком конца записи программы.

При записи программы на каждой строке можно писать либо по одному, либо по несколько операторов. Запись оператора можно начинать в любом месте строки. Ее можно продолжить на следующую строку, не разрывая имен констант, переменных, типов и символов. Кроме того, можно использовать пустые строки, чтобы отделить одну часть программы от другой.

Для записи исходных данных также можно использовать до 126 позиций строки. Числовые значения данных записываются на строке, отделяя одно от другого пробелами.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота