rubon
26.06.2020 00:20

Уровень A. Напишите программу, которая заменяет в символьной строке все точки на нули и все буквы X на единицы. Пример:
Введите строку: ..X.XX.
Двоичный код: 0010110

На Пайтоне сделайте

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
saruul708
24.03.2021 20:55
Дано номер деякого року (додатне ціле число). вивести відповідний йому номер століття, враховуючи, що, наприклад, початком 20 століття був 1901 рік.Дано номер деякого року (додатне ціле число). вивести відповідний йому номер століття, враховуючи, що, наприклад, початком 20 століття був 1901 рік.Дано номер деякого року (додатне ціле число). вивести відповідний йому номер століття, враховуючи, що, наприклад, початком 20 століття був 1901 рік.Дано номер деякого року (додатне ціле число). вивести відповідний йому номер століття, враховуючи, що, наприклад, початком 20 століття був 1901 рік.
0,0(0 оценок)
Ответ:
Romanova33
16.01.2021 11:56

Объяснение:

#include <iostream>

using namespace std;

long double fact(int N)

{

   if(N < 0) // если пользователь ввел отрицательное число

       return 0; // возвращаем ноль

   if (N == 0) // если пользователь ввел ноль,

       return 1; // возвращаем факториал от нуля - не удивляетесь, но это 1 =)

   else // Во всех остальных случаях

       return N * fact(N - 1); // делаем рекурсию.

}

int main()

{

   int N;

   setlocale(0,""); // Включаем кириллицу

   cout << "Введите число для вычисления факториала: ";

   cin >> N;

   cout << "Факториал для числа " << N << " = " << fact(N) << endl << endl; // fact(N) - функция для вычисления факториала.

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота