snezhanashikolai
18.05.2022 11:14

1)Написать программу поиска чисел, лежащих в интервале от -5 до 5, в последовательности чисел, вводимых с клавиатуры, предшествующих первому введенному нулю . Контрольный пример: 1,10,-4,5,-16,-5,0. 2)Дано число n от 1 до 1000 и число m. Вывести результат квадрат разности числа n и число m.

написать на языке Pascal​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
белка2010
26.08.2022 10:54

def solve(x, op, y):

   if str(op) == '+':

       try:

           print(float(x) + float(y))

       except ValueError:

           print('одно из значений не число')

   elif str(op) == '-':

       try:

           print(float(x) - float(y))

       except ValueError:

           print('одно из значений не число')

   elif str(op) == '*':

       try:

           print(float(x) * float(y))

       except ValueError:

           print('одно из значений не число')

   elif str(op) == '/':

       try:

           print(float(x) / float(y))

       except ZeroDivisionError:

           print('на ноль делить нельзя')

       except ValueError:

           print('одно из значений не число')

       return 0

   elif str(op) == '//':

       try:

           print(float(x) // float(y))

       except ZeroDivisionError:

           print('на ноль делить нельзя')

       except ValueError:

           print('одно из значений не число')

       return 0

   elif str(op) == '^':

       try:

           print(float(x) ** float(y))

       except ValueError:

           print('одно из значений не число')

   else:

       print('error')

   return 0

while True:

   num1, op, num2 = input().split()

   solve(num1, op, num2)

Объяснение:

Данные вводятся через пробел, ex:

Ввод: 2 + 2

Вывод: 4

0,0(0 оценок)
Ответ:
virki2018
21.03.2020 23:23

Вариант C:

#include <stdio.h>

#define SIZE 10

int main(void)

{

float result = 1;

float array[SIZE];

for(int i = 0; i < SIZE; ++i)

{

 scanf("%f", &array[i]);

 if(array[i] > 0 && (i % 6 == 0))

 {

  result *= array[i];

 }

}

printf("Произведение элементов, удовл. условию = %f", result);

return 0;

}

Вариант C++:

#include <iostream>

const int _size = 67;

int main()

{

float result = 1;

float arr[_size];

for(int i = 0; i < _size; ++i)

{

 std::cin >> arr[i];

 if(arr[i] > 0 && (i % 6 == 0))

 {

  result *= arr[i];

 }

}

std::cout << "Результат = " << result;

return 0;

}

Объяснение:

Проверяем элемент. Если он больше нуля и стоит на позиции, кратной 6, то добавляем в общее произведение.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота