ykukharsp0dngs
12.03.2022 17:33

Составление программ с использованием операторов циклов с предусловием и постусловием. Написать программу на языке Си. Составьте программу вычисления значения выражения для задаваемого натурального числа N: 6+12+18+...+6*N.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
113Diana113
26.08.2020 05:32
1. в 1902 году

2. считывание изображения и его конвертирование в цифровой формат

3. область сканирования, оптическое разрешение, тип матрицы сканера

4. Epson, canon, hp, Xerox

5. В результате преобразования света получается электрический сигнал, содержащий информацию об активности цвета в исходной точке сканируемого изображения. После оцифровки аналогового сигнала в АЦП цифровой сигнал через аппаратный интерфейс сканера идет в компьютер, где его получает и анализирует программа для работы со сканером. После окончания одного такого цикла (освещение оригинала — получение сигнала — преобразование сигнала — получение его программой) источник света  и приемник светового отражения перемещается относительно оригинала.

6. Сканеры в основном используются при переводе бумажных носителей в электронные. Вместе с хэш-функциями, которыми заверяют документы нотариусы, используются в делопроизводствах. Ручные сканеры используются в супермаркетах для считывания штрих-кодов. Перспективы развития у них низкие, разве что в уменьшении размеров, т.к. на современном уровне сканеры считывают изображения и электронный вид точно такой же, а после обработки даже лучше, как и у бумажного оригинала.
0,0(0 оценок)
Ответ:
Rian1338
01.08.2020 10:37
1.
using System;

class Program
{
        static void Main(string[] args)
        {
            int n=10;
            int[] a = new int[n];
            int k1=0;
            int k2=0;
            int k3=0;
            Random r = new Random();
            Console.WriteLine("Массив a:");
            for (int i = 0; i < n; i++)
            {
                a[i] = r.Next(41)-20;
                Console.Write("{0,5}", a[i]);
            }
            Console.WriteLine();
            for (int i = 0; i < n; i++)
            {
                if (a[i]>0) k1++;
                if (a[i]<0) k2++;
                if (a[i]==0) k3++;
            } 
            Console.Write("k1={0} k2={1} k3={2}", k1, k2, k3);
            Console.ReadKey();
        }
}

Пример:
Массив a:
   10 -19 10 -20 14 -11 8 -1 0 9
k1=5 k2=4 k3=1
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота