Heda0101
20.01.2020 15:38

Составьте программу (полный текст программы) для решения следующей . введите с клавиатуры три числа: а, в, с. если все они четные, то найдите и выведите на экран их сумму. если все они нечетные и a> b> c, то определите и выведите значения наибольшего и наименьшего из чисел. иначе, выведите числа без изменения. фрагмент программы: if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then begin s: =a+b+c; writeln('сумма равна ', s); end; if (a mod 2 < > 0) and (b mod 2 < > 0) and (c mod 2 < > 0) and (a> b) and (b> c) then begin writeln('наибольшее число ', a); writeln('наименьшее число ', c); end else writeln('a= ',a,' b= ', b, ' c= ',c);

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
papulova03
13.06.2020 14:05

var 

a,b,c,s:integer;

begin

readln(a,b,c);

 if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then

begin

S:=a+b+c; writeln('сумма равна ', S);

end;

if (a mod 2 <> 0) and (b mod 2 <> 0) and (c mod 2 <> 0) and (a>b) and (b>c) then

begin

writeln('наибольшее число ', A);

writeln('наименьшее число ', C);

end;

else

writeln('a= ',a,' b= ', b, ' c= ',c);

readln;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота