Колязнаток
02.04.2021 21:28

Впаскале составить программу: определить делимость на 3 для четырехзначного числа. (думаю, что надо использовать св-во делимости числа: число будет делиться на 3, если сумма цифр этого числа будет делиться на три)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Fiascobratan228
13.06.2020 13:35

var

  a: 1000..9999;

  a1, a2, a3, a4: 0..9;  //Цифры четырехзначного числа

 

begin

  writeln('Введите четырехзначное число');

  readln(a);

  a1:= a div 1000;

  a2:= (a mod 1000) div 100;

  a3:= (a mod 100) div 10;

  a4:= a mod 10;

  if (a1 + a2 + a3 + a4) mod 3 = 0 then writeln(a, ' делится на 3')

  else writeln(a, ' не делится на 3');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота