Bened
20.01.2022 14:48

Дан целочисленный массив из 30 элементов. Напишите программу, позволяющую найти наибольшее значение, которое является нечетным и делится на три. Язык PASCAL.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Artishokq
13.01.2023 22:33
Внешняя память - это память, предназначенная для длительного хранения программ и данных. Целостность содержимого ВЗУ не зависит от того, включен или выключен компьютер

Дисковод (накопитель) - устройство записи/считывания информации. Накопители имеют собственное имя – буква латинского алфавита, за которой следует двоеточие. Для подключения к компьютеру  одного или несколько дисководов и управления их работой нужен Дисковый контроллер

Носитель информации (носитель записи) – материальный объект хранить информацию. Информация записывается на носитель посредством изменения физических, химических и механических свойств запоминающей среды

По типу доступа к информации внешнюю память делят на два класса:

Устройства прямого (произвольного) доступа –  время обращения к информации не зависит от места её расположения на носителе;

Устройство последовательного доступа – такая зависимость существует

В состав внешней памяти входят:  1) накопители на жестких магнитных дисках (НЖМД);  2) накопители на гибких магнитных дисках (НГМД);  3) накопители на магнитооптических компакт дисках;  4) накопители на оптических дисках (CD-ROM);  5) накопители на магнитной ленте и др.

0,0(0 оценок)
Ответ:
emy2512
17.07.2021 18:41
Var
 x,a,b,c,max,min,mid:real;
begin
 readln(x);
 a:=sin(x);
 b:=cos(x);
 if a>0 then
  begin
   c:=ln(x);
   if (a>b) and (a>c) then max:=a else
   if (b>a) and (b>c) then max:=b else max:=c;
   if (a<b) and (a<c) then min:=a else
   if (b<a) and (b<c) then min:=b else min:=c;
   if (a>min) and (a<max) then mid:=a else
    if (b>min) and (b<max) then mid:=b else mid:=c;
   writeln(min,' ',mid,' ',max);
  end
 else
  if a>b then writeln(b,' ',a) else writeln(a,' ',b);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота